模拟队列
实现一个队列,队列初始为空,支持四种操作:
push x
– 向队尾插入一个数 x;
pop
– 从队头弹出一个数;
empty
– 判断队列是否为空;
query
– 查询队头元素。
现在要对队列进行 M 个操作,其中的每个操作 3 和操作 4 都要输出相应的结果。
输入格式
第一行包含整数 M,表示操作次数。
接下来 M 行,每行包含一个操作命令,操作命令为 push x
,pop
,empty
,query
中的一种。
输出格式
对于每个 empty
和 query
操作都要输出一个查询结果,每个结果占一行。
其中,empty
操作的查询结果为 YES
或 NO
,query
操作的查询结果为一个整数,表示队头元素的值。
数据范围
1≤M≤100000
1≤x≤1e9,
所有操作保证合法。
输入样例:
1 2 3 4 5 6 7 8 9 10 11
| 10 push 6 empty query pop empty push 3 push 4 pop query push 6
|
输出样例:
个人代码
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66
| #include<bits/stdc++.h> using namespace std; const int N = 100010; class Que{ int head = 0; int tail = 0; int val[N]; public: Que() {
} ~Que() {
} void push(int val) { this->val[head++] = val; } int pop() { return this->val[tail++]; } bool empty() { return head == tail; } int query() { return this->val[tail]; } };
int main() { Que* que = new Que; int n;cin>>n; while(n--){ string op;cin>>op; if (op == "push") { int val;cin>>val; que->push(val); } else if (op == "empty") { if (que->empty()) { cout<<"YES"<<endl; } else { cout<<"NO"<<endl; } } else if (op =="pop") { que->pop(); } else { int val = que->query(); cout<<val<<endl; } } }
|
板子
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
| #include <iostream>
using namespace std;
const int N = 100010;
int m; int q[N], hh, tt = -1;
int main() { cin >> m;
while (m -- ) { string op; int x;
cin >> op; if (op == "push") { cin >> x; q[ ++ tt] = x; } else if (op == "pop") hh ++ ; else if (op == "empty") cout << (hh <= tt ? "NO" : "YES") << endl; else cout << q[hh] << endl; }
return 0; }
|